Redoing adBricks’ logo
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Ad is famous for his paint skills, and this case is not different. So why not try making it better?
This will be the first real tutorial of this series. So I will have to make some things clear. Following this tutorial is on your own risk, I am not responsible for any damages physical, physical, or electronic. Any images posted here, by either me or other members, may not be used outside the topic without the creator’s permission.
No more legal stuff for now. Any corrections in either tutorial or langue are highly wanted.
For navigating in the menus I will use the following format: “Window | Menu -> Submenu -> Option [shortcut]”.
For this we will only need an image of a red 2x4 brick and the old image as reference. To make the brick you will need to have the following software installed: MLCad, LP3, LP3Add-on, LDraw, (maybe LGEO,) and POV-Ray. So I will just upload the image here instead…

(Source image, full size)

I couldn’t get the right camera angle in POV-Ray, so it is not going to match up completely.
Before we start, you will have to know about the basics about layers.
Layers are a fundamental part of Gimp and any other image manipulation program. Each layer is a separate image placed on top on the other layers. When you use the tools, it will only have effect on the active layer, all the others will remain unchanged. However using layers wouldn’t make much sense if you couldn’t make the layers transparent. You will see some of its uses later. 
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Let take a look at the Layers dialog. We will just skip “Mode setting”; you are probably not going to use it anyway. The opacity slider controls the opacity for the whole layer. You can also enter the value instead. It is quite useful if you need to know where something that is hidden beneath the layer you are working with.
Beneath you have the list of the layers in the active image. If you are working with multiple images, it will always show the current active image’s layers. Again, the tools will only work on the active layer in the active image. The active layer is the one selected in the list. The order of the list shows in which order the layers are used. The layer that is at the top at the list also be on the top on the other layers. The layer at the bottom will be beneath all the other layers.

To the left of all the layers you can see an eye icon. It is actually a button, it determines if a layer is visible or not. It does not change the opacity setting and you will still be able to work with the layer. However you will not be able to see what you have done on it until you make it visible again. (An exception is the preview option in some tools.)
Between the eye icon and the layer preview image, there is another button. (It will highlight if you hover your cursor on it.) If active, it will lock layers together with other layers which also have it active. If you try to move the layer, all layers that are “locked” will move too.
At the bottom of the layer dialog, there are six buttons. The first on the left will create a new layer; the two next will move it up and down the list. The fourth will make a copy of the active layer and the last deletes the layer. I will tell about the fifth button later. You can also do it in the list by dragging the layers to change the order or use the right click menu for the others.
Let get started. As the first thing, we should open the original logo. “Gimp | File -> Open… [Ctrl + O]” The “Open Image” window looks a bit different than the standard. But everything is mostly in the same place so it should be that difficult to figure out. A nice addition is you can add your own bookmarks to folders. But you will have to live without “mass-previewing”; it can only preview the selected image file.
Since gif is an indexed format, we will only be able to use 255 colours. But when editing, the colours will automatically be changed to fit the colour palette. It will be better to keep the colours and then generate a new colour palette to fit the new colours when done. In Gimp we have three choices: RGB, Greyscale, and Indexed. RGB has the highest colour depth, so it should always be the one you are working with. (Of cause there are exceptions) “adbricks.gif | Image -> Mode -> RGB”
The image is quite small; it would be easier if we zoomed in a bit. There is a lot of ways to do this. You can use the zoom tool [Z], it includes the option to automatic resize the window when zooming. The menu has a whole submenu to zoom only: “image | View -> Zoom (current zoom) -> …” The dialog called “Navigation” also has zoom controls and there is a dropdown menu in the status bar in the image window. The keyboard keys [+] and [-] and my favourite: [ctrl] + [mouse wheel]. Try to find the one you like the best, you are going to use it a lot.
When working in huge zooms, it is useful to have another view to see how it looks in original size. You can show another view by either “image | View -> New view” or using the dialog “Images”. In the new view you can change the view undependably of the other views, but it is still the same image, changing the image on one view will also show up on the others.
To make a summary of what we will have to do:
Find background colour

Make new layer

Add text

Add Lego brick to the logo

Scale layer

Align to original image

To find the colour we are going to use the Colour Picker Tool [O]. This tool will set the colour from the active layer and set it as the foreground colour (more about this later). However if the image is transparent, the colour it finds will be the same as if it hadn’t. If you want the colour that you see on the image as the combination of all the layers, you will have to check “Sample merged” in the tool options dialog. Another option for this tool is “Sample average” which takes all the pixels within the selected radius and finds the average.
But this tool will only work in the image; if you need to find a colour used on the screen you will have to use another. In the “FG/BG Color” dialog there is a tool that does just that. (The lowest button with the eyedropper icon.) It will not necessary work on transparent windows though.
When I’m going to change an image, I always dublicate the original image and work on that instead. This way, if something goes wrong, I will always have the original to start over again. However, this time the original is only to compare, so we will have to make a new layer anyway. So create the new layer with the Layers dialog. A window will show with the options for the new layer. Layer name is what the layer is called in the layers dialog. It really doesn’t matter what you call it (I will use “New Logo” for this tutorial) and if you accidentally call it the same as another layer, it will automatically suffix it “#1”. You can also change it later by right clicking on the layer and select “Edit Layer Attributes”. Width and Height is as standard the same as the image. It can be changed to whatever you like, even higher resolutions. The final image will only show the pixels inside the image borders though. Use the dropdown menu to select unit. Layer Fill Type determines what colour to fill the new layer with. Since we are going to use the old background colour that we made Foreground colour with the colour picker tool, “Foreground color” is the one to choose.
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The image right now should only show the background colour that you chose before. Before we continue, it would be a good idea to change the layer’s opacity to 50%.
Now to the text. We are going to use the old colour, so make the Background layer active and use the colour picker tool on the text without “Sample merged” checked.

With the text tool [T] click in the upper left corner. This will now bring up a window where you enter the text. You can write in multible lines, however you have to manually create all line shifts. Don’t worry about font and size yet, just click close when you have entered “adBricks”.
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You have probably noticed that even when we used the blue colour from the original without “Sample merged”, the text colour is the same as the original seen though our transparent layer. This is because we had the “background” layer active and our text is now beneath the “New logo” layer. But our text is placed on a special text layer and not bound to the “Background” layer, so we can easily place it on the top of “New logo”. Go to the layer dialog and drag the text layer so it is higher on the list than “New logo”. It will be named the same as the text it holds, but you can change it if you want. Gimp will automatically place a new layer just on top of the active layer, so if a new layer doesn’t show up, it might be hiding beneath another layer.
However now you changed the layer order, the text tool isn’t working on the old text, but on the text layer you might create next. In order to reselect it within the text tool, have the text layer active and click on the text with the text tool. It has to be on the text, it wouldn’t work if you just click within the layer selection. If you want to change the text, you will need to bring the text editor up by right clicking on the text layer in the layers dialog and select “Text tool”. It will also reselect the text layer in the text tool, but it is often easier to use the other method if you just had to move it or similar.
The Font can be selected in the dropdown menu that appears if you click on the “aa” button or by writing the first part of the font name. It will use the fonts installed on you system (“C:\Windows\Fonts\”). I used “Arial Black”, but if you don’t have it try finding a sans-serif font in blod. You wouldn’t be able to use the same settings as I either.
Beneath Justify there are three input boxes. The first (Indent) is how many pixels from the left or right (dependant on justify) there is between the text and starting point. The next (Line spacing) controls how much space there is between lines, the number is amount of pixels added or removed of the length. The next is the space between letters using the same system as before.
Settings used: (if not mentioned setting is standard)
Font: Arial Black

Size: 14px
Letter spacing: -1.0
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What there is left now is to add the brick. Click here to download (I will make a tutorial later on making the original image transparent) “adBricks.gif | File -> Open as Layers… [Ctrl]+[Alt]+[O]” It looks exactly like the normal open window, but it will open the image as a layer in the image.
Hmm, it is a bit too big don’t you think? For this we have the Scale tool [Shift]+[T].
You will need to zoom out first though. In the tool options you can choose what to scale under transform: layer, selection, or paths (I will cover paths in another tutorial). The “Keep aspect” option will lock the relationship between height and width so it should be checked in this case. Click on the layer to start. A window will pop up where you can enter the size, but you can use the mouse as well. The layer is outlined and there is a box in each corner and in the middle of each side. Drag in them to get it into the size you want. However ours are probably out of view because of the size. If you try to drag a random place inside the layer borders you also resize it. The circle with the cross is used to move the layer.
The dimensions I used is 43x36px. It is tempting just to enter the numbers, but since the layer is over 10 times as big, you have no idea where it will end up being. Resize it a bit first and then enter it.
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Everything is now where it should be; we could now call it done. But the Brick layer is a bit dark. We should make it a bit lighter. The tool “Brightness-Contrast” does that. Select the layer and “adBricks.gif | Colors -> Brightness-Contrast”. (It can also be accessed as a normal tool; however it is usually hidden in the main gimp window, use the tools dialog to bring it back.) Set Brightness and Contrast to about 30-40 and click ok.
I would like to change the colours so that it would match the forum colours. You should be able to do it yourself now (with new layer).
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